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L-Systems 1

These L-system activities are designed to help you create designs like the ones shown below.

     

Pretend that on the computer screen is a turtle facing towards the right. If you give the turtle the command ‘F’, 
the turtle will crawl forward one unit and will leave a mark on the screen as it crawls. If you give the turtle the 
command ‘G’, the turtle will crawl forward one unit, but will not leave a mark as it crawls.

So the command ‘FGFF’ will tell the turtle to crawl forward one unit while leaving a mark. Then it will crawl 
forward one unit without leaving a mark. Then it will crawl forward two units while leaving a mark. So the 
resulting drawing will look like this: 

Normally, to make a drawing that will be interesting, we want the turtle to be able to turn to the left or the right. 
The command ‘+’ makes the turtle turn to its left (i.e., counterclockwise). The command ‘-’ makes the turtle 
turn to its right (i.e., clockwise). Before giving the turtle the commands ‘+’ or ‘-’, we will tell the turtle how far 
to turn. The instruction ‘Angle 4’ will tell the turtle to turn 1

4  of a circle (i.e., 90°) whenever it is given a 
command of ‘+’ or ‘-’. The instruction ‘Angle 6’ will tell the turtle to turn 60° whenever we command it to 
turn (since 360°÷6 = 60°). Suppose the turtle is told ‘Angle 12’. Then it is commanded ‘F+F+F----F+F’. It will
1st crawl forward one unit. Then it will turn counterclockwise 30° (since 360°÷12 = 30°). Then it will crawl 
forward another unit (so the drawing now looks like this: ). Then it will turn left 30° again and crawl 
forward (now the drawing looks like this: ). Then it will turn right (i.e., clockwise) 4 times (for a total of 
120°). Then it will crawl forward once (the drawing now looks like this:  ). Then it will turn 
counterclockwise and crawl forward to finish the drawing.
Try to understand how the commands ‘F+F+F----F+F’ produce this drawing: .

To learn how to instruct the computer to make designs, start the program Elsys. Click Edit on the menu bar and 
then click New L-system.

After reading this paragraph, edit the text in the L-system window that appears so that it contains the commands 
that follow this paragraph. The first line of a formula contains the name of the formula and a brace (‘{’). The 
brace tells the computer that the formula is now beginning. The next line tells the turtle how far to turn when it 
receives a ‘+’ or ‘-’ command. You do not yet need to understand the significance of the word ‘Axiom’. Just 
make sure it is in the L-system. The commands for the turtle come after the word ‘Axiom’. The formula ends 
with a brace (‘}’). To quickly change the name of the L-system, double-click ‘New’ in the L-system window and 
type ‘Sample1 ’ (note the space at the end). Edit the text in the L-system window until it contains these commands:

Sample1 {
  Angle 12
  Axiom F+F+F----F+F
}

Be sure that ‘Sample1’ has no space in it. Put a 
space after ‘Sample1’ and before the brace (‘{’).

Save this paper for future reference.



To have the computer process the Sample1 L-system, click Edit on the menu bar and then click Process Shown 
Text. The Elsys window should then draw this design: .

To save the Sample1 L-system, click File on the menu and then click Save L-system To File. Then type your 
initials followed by “.AL”. For example, if you initials are PQR, then type PQR.AL for the file name. Then 
click the Save button.

Now select New L-system in the Edit menu and edit the text in the L-system window that appears so that it 
contains the commands that follow this paragraph. You do not need to type the text that is after a semicolon 
(‘;’). But you do need to type all of the text that is before a semicolon. If a line does not contain a semicolon, 
then type everything on that line.

Pentagon { ; Computer ignores text after a semicolon.
  Angle 5  ; 360/5 = 72. The text after a semicolon doesn’t need to be typed.
  Axiom F+F+F+F+F ; '+' = 'turn counter-clockwise one-fifth of a circle'
}

To have the computer process the Pentagon L-system, select Process Shown Text in the Edit menu. The Elsys 
window should then draw a pentagon. To save the Pentagon L-system, select Save L-system To File in the File 
menu. Then select the “.AL” file you saved above and click the Save button.

Now select New L-system in the Edit menu and edit the text in the L-system window that appears so that it 
contains the following commands:

Star { ; If text after a ';' isn’t typed, then the ';' doesn’t need to be typed either.
  Angle 10 ; 360/10 = 36. '-' = 'turn clockwise one-tenth of a circle'
  Axiom F----F----F----F----F
}

Select Process Shown Text in the Edit menu. The Elsys window should then draw a 5-pointed star. Using the 
procedure taught above, now save the Star L-system to your “.AL” file.

To watch how the turtle draws the star, select Debug in the Edit menu. In the Debug window, click Next on the 
menu bar to have the turtle move one unit. Answer the following questions (you may write on this paper):

1) Click Next again. The leftmost triangle in the Debug window should have rotated. Point the mouse at that 
triangle. The computer should display an angle measure. What is that angle measure?

2) Click Next again. Point the mouse at the leftmost triangle in the Debug window. The computer should 
display an angle measure. What is that angle measure?

3) Click Next. Write the new angle measure.

4) Click Next. Write the new angle measure.

5) Click Next. The turtle should crawl forward one unit. Now click Next four times to make the turtle turn four 
times. Write the new angle measure.

6) Click Auto. Watch the turtle. Once the turtle is done moving, what is the angle measure?

7) Click Next. This exits Debug mode. Select Open in the File menu. Select the “.AL” file you saved and click 
the Open button. Click Pentagon in the list of L-systems. Click OK. An Order window should appear. A 
later activity teaches about the “Order” concept. For now, just click OK in the Order window. This should 
draw a pentagon. Select Debug in the Edit menu. A window on the screen should show the commands 
F+F+F+F+F. The title bar of that window should show the text “Length:” followed by a number. Write that 
number.

8) Click Next in the Debug window. The first ‘+’ in the Length window should be selected. This means that ‘+’
is the next command. Click Next to perform that command. Write the new angle measure.

9) Click Auto. Write the angle measure once the turtle stops moving. You may now exit from Elsys.

Do not discard this activity.



Name ____________
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Start the program Elsys. Click Edit on the menu bar and then click New L-system. Edit the text in the L-system 
window until it contains these commands:
KochCurve2 { ; You do not need to type text that is after a semicolon.
  Angle 6  ; 360/6=60. '-' = 'turn clockwise one-sixth of a circle'
  Axiom FGF  ; Don’t forget there are braces at the beginning and the end!
  F=F+F--F+F   ; The lines after the axiom line contain substitution rules.
  G=GGG
}

To have the computer process the KochCurve2 L-system, select Process Shown Text in the Edit menu. Save the 
L-system as instructed in the first activity. Then select L-system Order in the Edit menu. In the window that 
pops up, type the digit 0 (zero). Click OK. Since the formula contains the command ‘Axiom FGF’, the turtle 
draws a segment. Then it moves forward without leaving a mark. Then it draws another segment.

Now select L-system Order in the Edit menu. In the window that pops up, type the digit 1 (one). Click OK. 
Since the order is 1, the computer uses the commands ‘F=F+F--F+F’ and ‘G=GGG’ to change the commands for 
the turtle. The command ‘F=F+F--F+F’ tells the computer to replace each ‘F’ in the axiom with the text ‘F+F--
F+F’. Likewise, the command ‘G=GGG’ tells the computer to replace the ‘G’ in the axiom with the string ‘GGG’. 
So the computer replaces the original command ‘FGF’ with the command ‘F+F--F+FGGGF+F--F+F’. The turtle 
uses this command to draw the diagram. The computer automatically resizes the diagram so that it fits on the 
screen. To watch how the turtle draws this design, select Debug in the Edit menu.

1) A window on the screen should show the commands F+F--F+FGGGF+F--F+F. The title bar of that window 
should show the text “Length:” followed by a number. Write that number.

2) Click Next in the Debug window. Write the symbol that is selected in the Length window.

3) Click Next in the Debug window. Point the mouse at the leftmost triangle in the Debug window. What is the
angle measure?

Click Exit in the Debug window. If the order were ‘2’, the computer would perform the substitutions a second 
time. The text that results at each step is shown in the following diagram. Each time, the computer replaces each
‘F’ with ‘F+F--F+F’ and replaces each ‘G’ with ‘GGG’.

Order 0 FGF

Order 1 F+F--F+FGGGF+F--F+F

Order 2 F+F--F+F+F+F--F+F--F+F--F+F+F+F--F+FGGGGGGGGGF+F--F+F+F+F--F+F--F+F--F+F+F+F--F+F

In this example, the substitution ‘F=F+F--F+F’ is equivalent to replacing each straight segment with the shape
. Change the order to 2 and see the substitution occur. Then change the order to 3 and see the 

substitution occur again.

Click Edit on the menu bar and then click New L-system. Edit the text in the L-system window until it contains 
these commands:
TriSpiral {
  Angle 3 ;360/3 = 120. '+' = 'turn counter-clockwise one-third of a circle'
  Axiom FYX ; As the turtle crawls, it ignores symbols it doesn't understand.
  Y=FY   ;When the turtle sees a Y, the turtle ignores it.
  X=+FYX
}

This formula contains symbols ‘X’ and ‘Y’. The turtle does not understand these symbols, so it ignores them. 
But as the computer computes orders 1, 2, 3, etc., it will follow the substitution rules ‘Y=FY’ and ‘X=+FYX’.

Do not discard this activity.



Select Process Shown Text in the 
Edit menu. Save the L-system. 
Select L-system Order in the Edit 
menu. Change the order to 0 and 
click OK. Also try orders 1, 2, 3, 
and 14. Select Curve Width in the 
Edit menu. Type the digit 3 and 
click OK.

Order Commands The part the turtle understands

0 FYX F

1 FFY+FYX FF+F

2 FFFY+FFY+FYX FFF+FF+F

Sometimes, to increase understanding of what the computer is doing, it can be helpful to have the turtle color 
the segments it draws. Edit the text in the L-system window until it contains these commands:
TriSpiralColor { ; In the default color palette, color 15 is white.
  Angle 3      ; Text after a semicolon is ignored by the computer.
  Axiom C15FYX ; 'C15' tells the turtle to chose color 15.
  Y=>1FY       ; '>1' tells the turtle to decrease the color number by 1.
  X=+C15FYX    ; After each turn, chose color 15 again.
}

Select Process Shown Text in the Edit menu. Save the L-system. Try orders 1, 2, 3, and 4 to see how the turtle 
colors different segments. Then try order 14. Notice how the first segment at the bottom-left is white (color 15). 
The next segment is color 14. The next segment is color 13, etc. Then when the turtle turns 120°, it chooses 
color 15 (white) again. To see the color palette, select Show Editable Color Map in the Edit menu.

4) Point the mouse at the white square in the color palette. The computer should show two lines of information.
The first line shows that the color number is 15. Write the entire second line of information.

5) The second line of information shows the red, green, and blue values for the color. Move the mouse around 
until you find color # 14. What are the red, green, and blue values for color 14?

Change the order to 3. For each one of the following three L-systems, first edit the L-system window so that it 
contains the L-system. Then select Process Shown Text in the Edit menu. Then save the L-system.
Snow { 
  Angle 6
  Axiom F+F+F+F+F+F
  F=F+FF+F--F--F+FF+F
}

SnowColor { ; Try order 4 or 5
  Angle 6 ; '<2' --> increase color # by 2
  Axiom C2F+<2F+<1F+<2F+<4F+<2F
  F=F+FF+F--F--F+FF+F
}

SnowColor2 { ; Try order 1 or 2
  Angle 6 ; '>2' --> decrease color # by 2
  Axiom F+F+F+F+F+F
  F=C13F+>2F>2F+>2F-->1F-->1F+>1F>1F+>1F
}

6) Select Open in the File menu. Select the “.AL” file you saved. Choose Snow in the L-system list and click 
OK. Type 0 for the order and click OK. Name the shape produced.

7) Change the order to 1. Choose Show Command String Text in the Edit menu. The title bar of the Length 
window shows the length of the command string text. What is that length?

8) Select Choose L-system in the File menu. Choose SnowColor2 in the L-system list and click OK. Make sure 
the order is 1 and click OK. Select Show Command String Text in the Edit menu. What is the length 
displayed in the title bar of the Length window?

9) Select Choose L-system in the File menu. Choose SnowColor in the L-system list and click OK. Make sure 
the order is 1 and click OK. Select Debug in the Edit menu. What is the length displayed in the title bar of 
the Length window?

10) Click Next in the Debug window. Remember the new color of the turtle. Now continue to click Next until 
the turtle turns a different color. What is the measure of the angle for the turtle?

11) Click Exit in the Debug window. Change the order to 4. Choose Show Command String Text in the Edit 
menu. A window should pop up. Don't click any buttons. According to the window that pops up, how long 
is the command string?

12) Click No. Change the order to 3. Choose Show Command String Text in the Edit menu. How long is the 
command string?

IMPORTANT NOTICE (Do not discard)
If you need to change an L-system after 
saving it, open the “.AL” file in Notepad 
and edit that file and then save it. Then 
select Open in the File menu in Elsys to 
reopen the changed “.AL” file.

The Snow design should look similar to the top-left design on the L-Systems 1 activity. If you saved a flawed L-system, see the IMPORTANT NOTICE above.



Name ____________
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Start Elsys. Select New L-system in the Edit menu. For each of the following three L-systems, type the L-system
in the L-system window and then process the text and then save the L-system.

KochCurve3 {
  Angle 6
  Axiom F!F!F
  F=F+F--F+F
}

KochCurve3Color {
  Angle 6
  Axiom C5FC7!F!C11F 
  F=F+F--F+F
}

Zigzag {
  Angle 3
  Axiom F
  F=F!-F
}

The ‘!’ command tells the turtle to reverse the meaning of ‘+’ and ‘-’. In the axiom ‘F!F!F’ the ‘!’ command 
has no effect (since there are no ‘+’ or ‘-’ commands). But when the computer applies the substitution rule, the 
‘!’ command does have effect. After applying the substitution ‘F=F+F--F+F’ to the axiom ‘F!F!F’, the 
command will be ‘F+F--F+F!F+F--F+F!F+F--F+F’. Normally, ‘+’ means ‘turn counterclockwise’ and ‘-’ 
means ‘turn clockwise’. After the turtle receives the 1st ‘!’ command, it will interpret ‘+’ as ‘turn clockwise’ 
and ‘-’ as ‘turn counterclockwise’. When the turtle is given the next ‘!’ command, it again reverses the 
meanings of ‘+’ and ‘-’. So now they are back to their original meanings.

Open the file to which you saved the above three formulas and choose KochCurve3 and click OK. Type the digit
1 for the order and click OK. Then select Debug in the Edit menu. Notice that an ‘N’ is displayed in the Debug 
window. This means that ‘+’ and ‘-’ have their normal meaning. Click Next in the Debug window until the first
‘!’ is selected in the Length window. The Debug window should still show an ‘N’.

1) Click Next one more time. Write the letter that is now displayed instead of the ‘N’.

2) Click Next two more times. What is the angle measure for the turtle?

3) Click Next in the Debug window until the second ‘!’ is selected in the Length window. Then click Next 
three more times. What is the angle measure for the turtle?

4) Click Exit. Select Choose L-system in the File menu. Choose  KochCurve3Color, click OK, type the digit 2 
for the order, and click OK. Select Debug in the Edit menu. Observe the ‘N’ in the Debug window. Click 
Auto in the Debug window and watch both the ‘N’ and the turtle. What is the color of the design when the 
meanings of ‘+’ and ‘-’ are reversed?

5) Click Exit. Select Choose L-system in the File menu. Choose  Zigzag, click OK, type the digit 4 for the 
order, and click OK. Select Debug in the Edit menu. Click Auto. When the turtle is finished moving, what is 
the meaning of ‘-’? (Use words in the answer. Read the top paragraphs on this page if you have questions.)

Click Exit. Enter the following L-system, process it, and save it.

OctSpiralColor {
  Angle 8
  Axiom C16F
  F=F<1+@.99F ;'@' is the 'at' symbol which is found on the key for '2' on many keyboards
}

The ‘@.99’ command tells the turtle to crawl 99/100 as far as it used to crawl when it would be commanded ‘F’ 
or ‘G’. For order 2 (i.e., after 2 substitutions), the command will be ‘C16F<1+@.99F<1+@.99F<1+@.99F’. For the
1st ‘F’, the turtle will crawl the normal distance. For the 2nd ‘F’, the turtle will crawl 0.99 of the original distance.
For the 3rd ‘F’, the turtle will crawl 0.99 of that new distance which means that it will crawl 0.9801 of the 
original distance.

6) Do order 8 of OctSpiralColor. Select Spectrum Map in the Edit menu. Select Debug in the Edit menu. 
Observe the number 1 displayed in the Debug window. Click Next until that number changes. Write the new
number.

Hint: Instead of clicking Next in the Debug window, you may press N on the keyboard if that window is 
active. Also, you may press A instead of clicking Auto, and you may press  instead of clicking Exit.

IMPORTANT NOTICE (Do not discard)
To delete an L-system after saving it, open the “.AL” file in 
Notepad and delete the entire L-system (including the name 
and both braces). Then save the file. Then select Open in the 
File menu in Elsys to reopen the changed “.AL” file.



7) Click Next until the number changes again. Write the new number.

8) Click Next until the number changes again. Write the new number.

Click Exit. Change the order to 3. Select Elsys Map (Default) in the Edit menu. Select New L-system in the 
Edit menu. For each of the following three L-systems, type the L-system in the L-system window and then 
process the text and then save the L-system. The ‘|’ symbol may look like ‘¦’ on the keyboard.
KochAlt2 {
  Angle 6
  Axiom F|F
  F=F+F--F+F
}

KochAlt6 {
  Angle 6
  Axiom F|FF|F+F|FF|F+F|FF|F
  F=F+F--F+F
}

KochAlt6Color {
  Angle 6
  Axiom C2F|F<2F|F+<1F|F<2F|F+<2F|F<2F|F
  F=F+F--F+F
}

If the ‘Angle’ command is an even number, then the ‘|’ command tells the turtle to turn 180°. So in KochAlt2, 
the axiom ‘F|F’ is equivalent to ‘F+++F’. At order 0, ‘F|F’ causes the turtle to crawl forward, then turn around 
and crawl back the way it came. So at order 0, the extra ‘F’ is not visible. At order 1 (after substituting ‘F+F--
F+F’ for each ‘F’ in ‘F|F’), the command will be ‘F+F--F+F|F+F--F+F’.

9) Open the file to which you saved the above 3 formulas. Select KochAlt2 and let the order be 1. How many 
line segments are visible in the design?

10) Change the order to 2. The design should have 3 polygonal regions. How many sides does the central 
polygon have?

11) Change the order to 3. How many polygonal regions are in the design?

12) Select Choose L-system in the File menu. Choose  KochAlt6 and let the order be 1. Select Debug in the Edit 
menu. Click Auto. When the turtle is finished moving, what is its angle measure?

13) Click Exit. Change the order to 5. Select Show Command String Text in the Edit menu. What is the length of
the text?

14) Select Choose L-system in the File menu. Choose  KochAlt6Color and let the order be 2. Select Debug in the
Edit menu. Click Next until the turtle is at the rightmost point in the design. Click Next one more time. The 
turtle should have changed its direction. By how many degrees did it change its direction?

15) Keep clicking Next until the turtle changes its color. What is its new color?

16) Keep clicking Next until the turtle changes its color again. What is its new color? (Make sure that the answers to 
#15 and #16 are different. If they are the same, you probably need to change the answer for #15)

17) Click Exit. Press  on the keyboard. The Elsys Help window should appear. According to the information 
in it, who introduced L-systems?

IMPORTANT NOTICE (Do not discard)
To temporarily “delete” an L-system after saving it, open the “.AL” file in Notepad and type a semicolon at the beginning of each line of the L-system (including the 
name and the ending brace). Then save the file. This causes Elsys to ignore those lines since a semicolon indicates the beginning of a comment.
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Start Elsys. Select New L-system in the Edit menu. For each of the following three L-systems, type the L-system
in the L-system window and then process the text and then save the L-system.

DoubleSpiral {
  Angle 40
  Axiom ----[F]|F
  F=F+@.98F
}

FlakeV { 
  Angle 5
  Axiom F+F+F+F+F
  F=F+F[+F]--F+F
}

FlakeVColor {
  Angle 5
  Axiom C2F+<2F+<1F+<2F+<4F
  F=F+F[+F]--F+F
}

The ‘[’ command tells the turtle to remember its current condition (its position, direction, color, length of crawl,
and meaning of ‘+’ and ‘-’). Then when the turtle is given the ‘]’ command, it goes back (without leaving any 
marks) to the condition it had been in when it was given the ‘[’ command. 

1) Open the file to which you saved the above formulas. Choose DoubleSpiral and let the order be 5. Choose 
Debug in the Edit menu. Click Next until the ‘[’ is selected in the Length window. Then click Next again. 
The Debug window should now show two lines of information. Look at the two triangles in the left column. 
What is the angle of the top triangle?

2) What is the angle of the bottom triangle?

3) Click Next until the ‘]’ is selected in the Length window. Now what is the angle of the top triangle?

4) What is the angle of the bottom triangle?

5) The right column in the Debug window shows the crawl length for the turtle. Write both the current crawl 
length (top line) and the remembered crawl length (bottom line) with as much precision as is displayed in 
the Debug window.

6) While watching the turtle, click Next. The remembered conditions have now become the current conditions. 
Click Next again. What is the current angle measure for the turtle?

7) Click Next two more times. By how many degrees did the angle measure change?

8) Click Exit. Select Choose L-system in the File menu. Choose FlakeV with an order of 1. How many 
pentagons are in the design?

9) Change the order to 5. Select Show Command String Text in the Edit menu. A window should pop up. 
Carefully read it, but don't click any buttons. According to that window, what is the length of the command 
string?

10) Click No. Select Choose L-system in the File menu. Choose FlakeVColor with an order of 2. Choose 
Debug in the Edit menu. Click Next until the first ‘[’ is selected in the Length window. Then click Next until
the first ‘]’ is selected. Then click Next until the 2nd ‘[’ is selected. Then click Next until the 2nd ‘]’ is 
selected. Then click Next until the 3rd ‘[’ is selected. Then click Next until the 4th ‘[’ is selected. Click Next 
three more times. The Debug window should show 3 lines of information. The left triangle in the first line 
shows the current angle of the turtle. The left triangle of the 2nd line shows the most recently remembered 
angle. The left triangle of the 3rd line shows an angle that had been remembered earlier. Write all three angle
measures, starting with the current angle.

11) The Elsys window shows two small circles drawn on the design. The one circle is larger than the other. The 
smaller circle shows the most recently remembered location. The larger circle shows an earlier remembered 
location. Carefully watch the larger circle as you click Next. What happens to that circle?

12) Click Next until the turtle turns green. What is its angle measure?

13) Click Exit. Change the order to 5. Observe how the different colors are distributed around the design. 
Studying colors can help to increase understanding regarding how the turtle crawls. Press . Find where 
Elsys Help teaches that the ‘[’ command is called a “Push” command. What is the ‘]’ command called?
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Start Elsys. Select New L-system in the Edit menu. For each of the following two L-systems, type the L-system 
in the L-system window and then process the text and then save the L-system.

KochSnow {  
  Angle 12
  Axiom +F----F----F
  F=F++F----F++F
}

KochSnowBuild { 
  Angle 12
  Axiom +FY----FY----FY
  F=    ;This is not a mistake
  X=FY
  Y=FX[F]++FX----FX++FX
}

The Koch snowflake is named after Helge von Koch. KochSnow can help you visualize the design.

1) Open the file to which you saved the above formulas. Choose KochSnow and let the order be 0. How many 
line segments are in the design?

2) Change the order to 1. How many line segments are in the design?

3) Change the order to 2. How many line segments are in the design?

4) Change the order to 5. This should give you some idea of how the Koch snowflake would look. An infinite 
order would be needed to produce the actual Koch snowflake. Select Show Command String Text in the Edit
menu. What is the length of that text?

5) Select Choose L-system in the File menu. Choose KochSnowBuild and let the order be 0. This L-system 
contains the substitution rule ‘F=’ (with nothing after ‘=’). This rule will replace ‘F’ with nothing (i.e., it will
delete each ‘F’). This L-system shows one way of visualizing the construction of the Koch snowflake. What 
special type of triangle is displayed when the order is 0?

6) Change the order to 1. This places an equilateral triangle on the middle third of each side of the original 
triangle. Now change the order to 2. This should erase the boundaries between the original triangle and the 
little triangles. Now change the order to 3. How many little triangles does this add to the design?

7) Change the order to 4. This should erase the boundaries between the main design and the little triangles. 
Change the order to 5. Select Debug in the Edit menu. Click Next until the first ‘]’ is selected in the Length 
window. Write both the current angle measure for the turtle and the remembered angle measure.

8) Click Next three times. What is the current angle measure?

Click Exit. Select New L-system in the Edit menu. For each of the following two L-systems, type the L-system 
in the L-system window and then process the text and then save the L-system.

QBlock2 {
  Angle 8
  Axiom F++F++F++F
  F=F[++F]G[@Q8+F]G++G|F++F
  G=GGGG ;4 G’s
}

Quilt2 {
  Angle 8
  Axiom F++F++F++F
  F=F[++F--F]@I2G@Q2+F++F++F++F@IQ2+G@2[++!F]F
  G=GGG ;3 G’s
}

9) In QBlock2, the command ‘@Q8’ multiplies the turtle’s crawl length by the square root of 8. In Quilt2, the 
command ‘@I2’ multiples the crawl length by the inverse of 2 (i.e., 1

2 ). The command ‘@IQ2’ multiplies the 
crawl length by the inverse of the square root of 2. Do order 1 of Quilt2. How many squares are tilted?

10) The commands for drawing tilted squares are found between the commands ‘@Q2’ and ‘@IQ2’. The 
command ‘@IQ2’ restores the crawl length to what it had been before the ‘@Q2’ command. Select Debug in 
the Edit menu. Click Next until the first ‘@I2’ is selected. What is the current crawl length?



11) Click Next once. What is the new crawl length?

12) Click Next twice. Write the new crawl length rounded to three decimal places.

13) Click Next until the first ‘@2’ is selected. What is the current crawl length?

14) Click Next once. What is the new crawl length?

15) Click Exit. Change the order to 5. Select Show Command String Text in the Edit menu. A window should 
pop up. Do not click any buttons. According to the window that pops up, what is the length of the command 
string?

16) Click No. Open the file to which you saved the formulas. Choose QBlock2 and let the order be 1. Select 
Show L-system Text in the Edit menu. The command for drawing one side of the large tilted square is the ‘F’
in ‘[@Q8+F]’. Notice that at the ‘]’ command, the turtle returns to the condition it had been in when it 
received the ‘[’ command – including the size of the crawl. So the command ‘@IQ8’ was not needed to 
restore the crawl length to its original size. How many squares are in the design?

17) Select Debug in the Edit menu. Click Next until the first ‘@Q8’ is selected. What is the crawl length?

18) Click Next once. Write the current crawl length rounded to 3 decimal places.

19) Click Next twice. What is the current angle measure?

20) Click Next once. Write both the current angle and crawl length.

21) Click Exit. Change the order to 2. How many tilted squares are in the design?

22) Study the central square in the order 2 diagram. Then study the central squares for orders 3, 4, and 5. How 
does the central square in an odd order compare to the central square in an even order?
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Start Elsys. Select New L-system in the Edit menu. For each of the following two L-systems, type the L-system in 
the L-system window and then process the text and then save the L-system.

FlakeIXb {
  Angle 9
  Axiom F+F+F+F+F+F+F+F+F
  F=F+F+F[+F+F+F]|F+F+F 
;For Angle 9, '|'='+++++' for default meaning of '+'
}

MultiSpiral6G {; Try order 88
  Angle 40
  Axiom ----[FX]|FX
  X=[@.35Y][|@.35Y]+@.98F+@.98FX
  Y=++@.964FY
}

1) If the # in the command ‘Angle #’ is even, then ‘|’ tells the turtle to turn 180°. If the # is odd, then the turtle 
will turn counterclockwise 180° and will keep turning until it reaches a multiple of 360° ÷ #. For ‘Angle 9’, 
360° ÷ 9 = 40°. Since 4(40°) = 160° and 5(40°) = 200°, ‘|’ tells the turtle to turn counterclockwise 200° 
(equivalent to turning clockwise 160°). So when ‘+’ and ‘-’ have their normal meanings, the ‘|’ is equivalent 
to ‘+++++’ which is equivalent to ‘----’. Open the file to which you saved the above formulas. Choose 
FlakeIXb and let the order be 1. Select Debug in the Edit menu. Click Next until the first ‘|’ is selected in the 
Length window. What is the current angle measure for the turtle?

2) Click Next once. What is the current angle measure for the turtle?

3) Click Next until the next ‘|’ is selected in the Length window. What is the current angle measure for the turtle?

4) Click Next once. By how many degrees did the angle measure change?

5) Click Exit. MultiSpiral6G was derived from the DoubleSpiral formula of a previous activity. Order 8 works 
well for DoubleSpiral, but MultiSpiral6G needs a much higher order. Select Choose L-system in the File 
menu. Choose MultiSpiral6G with an order of 88. Select Show Command String Text in the Edit menu. 
According to the window that pops up, what is the length of the command string?

6) Click No. Change the order to 3. Select Debug in the Edit menu. Click Next until the first ‘]’ is selected in the 
Length window. What is the current angle measure for the turtle?

7) Click Next once. What is the current angle measure for the turtle?

8) Click Next until the next ‘]’ is selected in the Length window. What is the current angle measure for the turtle?

9) Click Exit. Open “Elsys.AL” (Important: If it doesn’t exist, select Write Elsys.AL in the File menu and click the Save button. 
Then open “Elsys.AL”). Choose FlakeX and let the order be 4. Then change the order to 1. The design consists of 
10 congruent regular polygons joined together. What is the name for those polygons?

10) Open “Fractint.L” (If it doesn’t exist, select Write Fractint.L in the File menu and click the Save button. Then open “Fractint.L”).
Choose Bush and let the order be 4. Select Show L-system Text in the Edit menu. Write the axiom (If you don't 

know what the axiom is, press  and read Elsys Help until you understand).

11) Select Choose L-system in the File menu. Choose Curve4 and let the order be 6. Also try orders 7, 8, and 9. 
Concerning the overall design, how do the odd and even orders differ from each other?

12) Now choose Fass1 and let the order be 4. Then choose Peano2 and let the order be 4. Select Show L-system 
Text in the Edit menu. Write the axiom.

13) Now choose Penrose4 and let the order be 4. Select Show L-system Text in the Edit menu. Write the axiom.

14) Now choose Island1 and let the order be 2. The design consists of three sizes of islands. There is one large 
island. How many medium islands are in the design?

If you develop any interesting designs, the instructor would be interested in seeing the formulas and pictures.
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Observe that each of the following L-systems has a tilde (~) immediately after the opening brace. This tilde tells 
Elsys that the L-system is an arc L-system. In an arc L-system, ‘L’ tells the turtle to draw an arc of a circle while 
turning to the left (i.e., counterclockwise), and ‘R’ tells the turtle to draw an arc of a circle while turning to the right
(i.e., clockwise). Start Elsys. Select New L-system in the Edit menu. For each of the following four L-systems, type
the L-system in the L-system window and then process the text and then save the L-system.

Rapids {~ ;order 4
  Angle 5
  Axiom A
  A=RLA
}

Spiral4c {~ ;order 5
  Angle 4
  Axiom C16L
  L=L@.9<1L
}

Spirals8c {~ ;order 50
  Angle 8
  Axiom C16Y
  X=@.93LX
  Y=+@.9[@.4LX]G<2Y
}

Spirals9c {~ ;order 70
  Angle 9
  Axiom C16KZ
  K=@.9LKR@I.9
  Z=<1@.9LKZ
}

1) Open the file to which you saved the above formulas. Choose Rapids and let the order be 4. Select Debug in 
the Edit menu. What is the length of the command string? How many times does ‘L’ appear in the command 
string?

2) Click Next once. What is the current angle measure for the turtle? Study the arc traced by the turtle. Did the 
turtle turn clockwise or counterclockwise as it made the arc? By how many degrees did the turtle turn as it 
made the arc? Hint: the initial angle of the turtle can be thought of as being 360°.

3) Click Auto. What is the final angle measure for the turtle?

4) Click Exit. Select Choose L-system in the File menu. Choose Spiral4c with an order of 5. Select Debug in the 
Edit menu. What is the length of the command string?

5) Carefully watch the turtle. Click Next once. What happened to the turtle when Next was clicked?

6) Click Next again. Did the turtle turn clockwise or counterclockwise as it made the arc? By how many degrees 
did the turtle turn?

7) Click Next until the third ‘L’ is selected in the Length window. When the turtle draws an arc, it uses its linear 
crawl length for the radius of the circle that contains the arc it will draw. What is the current crawl length for 
the turtle?

8) Click Auto. When the turtle is done crawling, write the displayed crawl length to 5 decimal places.

9) Click Exit. Select Choose L-system in the File menu. Choose Spirals8c with an order of 50. Press W on 
keyboard and change the width to 3. The design should show a spiral of spirals. If we start counting with the 
biggest spiral at the bottom of the window and go counterclockwise, the 3rd spiral should be yellow and the 4th 
spiral should be green. Which spiral is the next yellow spiral? Which spiral after that one is the next yellow 
spiral?

10) Select Debug in the Edit menu. Click Next until the first ‘]’ is selected in the Length window. Write the current
crawl length rounded to 6 decimal places.

11) Click Next two more times. What is the current angle measure for the turtle?

12) Click Exit. Select Choose L-system in the File menu. Choose Spirals9c with an order of 70. The design 
should show a spiral of connected spirals. Select Debug in the Edit menu. What is the length of the command 
string?

13) Click Next three times. What is the current angle measure for the turtle?

14) Look over the command string and find the first ‘<1’. Click Next once. Then press N on the keyboard until 
that first ‘<1’ is selected. What is the current angle measure for the turtle?


